Question regarding re-attaching databases

We tried to backup a database for RMS by going through Management Studio, d etaching the database, copying out the mdf and ldf files and reattaching. P
roblem is, whenever we tries to reattach, no matter what name he gives the database, and no matter what computer he tries, it says that the database a lready exists.
If you query the sys.databases table, the database we try to attach won't b e there, but then after getting the error that the db already exists, it wi ll mysteriously appear in the sys.databases table. It will even say that th e database exists on brand new installs of SQL.
I have a feeling that there's an issue with the master dbs but I can't say I've ever seen this problem before so I'm not sure exactly how to fix it. A ny ideas?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

BeanSmart.com is a site by and for consumers of financial services and advice. We are not affiliated with any of the banks, financial services or software manufacturers discussed here. All logos and trade names are the property of their respective owners.

Tax and financial advice you come across on this site is freely given by your peers and professionals on their own time and out of the kindness of their hearts. We can guarantee neither accuracy of such advice nor its applicability for your situation. Simply put, you are fully responsible for the results of using information from this site in real life situations.