Epson Printer Health Check OPOS_E_ILLEGAL

I am trying to attach an epson printer TM-T88III to one of my terminals. I am using the epson ADK ospos software to set up the printer. When doing the
health check I keep getting the result OPOS_E_ILLEGAL.
I can not for the life of me figure out why I am getting this result. I have tested the printer and it is working perfectly (I took if off of a different machine that was working perfectly)
Any ideas what is causing this?
Thanks! -JT
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Is it usb or parallel ? Remove the OPOS and reinstall again and It will ask you for port usb or Perallel. and If you have usb printer click usb if you have perallel click on perallel.You should install opos newer version with service pack 10. or you can can call epson http://www.esponexpert.com They will help you free.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

BeanSmart.com is a site by and for consumers of financial services and advice. We are not affiliated with any of the banks, financial services or software manufacturers discussed here. All logos and trade names are the property of their respective owners.

Tax and financial advice you come across on this site is freely given by your peers and professionals on their own time and out of the kindness of their hearts. We can guarantee neither accuracy of such advice nor its applicability for your situation. Simply put, you are fully responsible for the results of using information from this site in real life situations.